
What’s New in OMEGA 2.5 

GERBER OMEGA 2.5 includes many new features for improving design and workflow. These 
are some of the major improvements to OMEGA 2.5: 

♦ Improved Adobe Illustrator AI, CS, PDF, EPS, and Postscript import capabilities 

♦ Improved designing and displaying of vinyl-only jobs 

♦ Clipping Paths or image masks 

♦ Dimensioning tools 

♦ The ability to embed images into a .PLT file 

♦ The ability to design and output by layers 

♦ More fonts included with new seats of OMEGA 2.5 and upgrades 

♦ And more! 

Review this document and see OMEGA Help for details on using these exciting features! 
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System requirements 

Note: OMEGA 2.5 is compatible with Windows® 2000 and Windows XP. OMEGA 2.5 is not 
tested or supported for use with Windows ME, Windows 95, Windows 98, or Windows NT 
4.0.  See Getting Started for detailed hardware and software requirements. 

♦ Recommended hardware: 

♦ Pentium III or later 

♦ 512 MB RAM minimum 

♦ 2 GB hard disk (20+ recommended) 

♦ CD-ROM drive  

♦ Ports: 1 parallel, 2 serial , and at least 2 USB  

♦ VGA Color Monitor (minimum resolution 1024 x 728) 

 

OMEGA 2.5 defaults 
The defaults for layers and embedded images is OFF, making OMEGA 2.5 behave similarly to 
previous versions of OMEGA. This has been done to allow customers to transition into the 
features they want to learn at their own pace. 

♦ Designing occurs on a single layer like previous versions of OMEGA.  Layers can be 
added by using the New Layer command in Layer Manager. 

♦ The layer manager is not shown when Composer opens. You must select the option in 
the View menu. 

♦ Legacy PLT files and other file types import and open flattened onto the current layer . 

♦ Non-OMEGA files that are opened or imported (AI, PDF, EPS, CMX, etc) are flattened 
onto a single layer. This can be changed and preferenced in the Open or Import dialog 
box in Composer.                

♦ If layers are used, the Edit All button is ON so you can edit all objects at once even if 
they are not on the same layer.  

♦ The Output by Layers option is OFF so jobs have a single print order (not layered) for 
the entire job. 

♦ GSPPlot will output layered images as a single layer job with a single print order. 

♦ Images remain linked or not embedded. 
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New Features and Enhancements 

Improved Postscript and PDF import/export using (GSP 2.5) filters 
OMEGA 2.5 now has new file conversion filters that allow for the import of postscript and PDF 
file types. The import filter list has been reorganized and filters have been renamed for clarity. 
 

File Type Updates Adds: 

Adobe Illustrator (AI) 7.0, 8.0, 9.0, 10.0, 11.0 (CS)

Portable Document Format (PDF) PDF 1.3 (Acrobat 4), PDF 1.4 (Acrobat 5), PDF 1.5 (Acrobat 6)

EPS Supported from Adobe CS 2 and lower

PostScript Level 2 and 3, EPS, PS (Level 2 and 3)

♦ Text does not need to be converted to curves in other design programs to be imported 
into OMEGA when using GSP 2.5 filters. However, text appears in OMEGA as 
outlines that are not editable. 

♦ If using GSP 2.1 filters, it does need to be converted. 

♦ If GerberColor spot colors or GSP vinyl colors are assigned in Adobe Illustrator using 
the included Illustrator Palettes or Corel Draw, these colors import into OMEGA with 
the colors and names intact. 

♦ Layers, overprints, gradients, clipping paths, strokes, dashed strokes, images and 
other features from the original file are maintained in OMEGA. Advanced gradients 
and other features are automatically converted to images with clipping paths. 

♦ Files can be converted as vectors or as images. If converted as images, the resolution of 
the file can be chosen. 

♦ The OMEGA 2.1 AI and EPS import filters remain available to allow for duplication of 
previous conversions and to import files from Illustrator version 1.1 through 8. 

♦ The Harlequin Postscript Option is no longer available or supported. All the 
functionality is included in OMEGA 2.5 Postscript import capabilities. 

Improvements to vinyl-only designing 
Designing and displaying vinyl-only jobs has been improved in OMEGA 2.5: 

♦ The vinyl-only display mode has been removed. This allows for vinyl-only objects to 
be moved “to front ” and “to back ” of each other consistently and without display 
issues. 

♦ The same vinyl color in vinyl-only jobs can be in front or in back of other objects. 

♦ Vinyl-only objects of the same color such as rectangles, circles, or imported objects 
must now be combined using the combine option in the Arrange menu to knock out 
one shape from another. 

♦ Vinyl-only text combines automatically. 
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♦ Legacy files from previous versions of OMEGA and GRAPHIX ADVANTAGE 
combine automatically to make shapes knock out. 

♦ Vinyl-only jobs can be designed with layers. If using layers, the same vinyl color can 
reside on different layers, offering the ultimate in display and output stacking 
flexibility. 

♦ If EDGE fills are added to a vinyl-only job, OMEGA displays in a print-order mode 
instead of a vinyl-only mode. Vinyl-only objects will show knock-outs automatically 
but you lose the to-front and to-back flexibility mentioned above. 

Clipping Paths or Masks 
Clipping Paths are like cutting holes in a piece of paper and placing it on top of an object so 
only the parts that show through the holes are visible. Clipping paths limit the display of 
specified objects by drawing only the parts of the objects that fall within the path and not the 
parts that fall outside.  The Clipping Path container (“Clipper”) and the clipped object 
(“Clippee”) must be on the same layer and the path must be in front of the clipped object.  

 

To make a clipping path, select the 
Clipping path container and the 
clipped path using the shift key.     
In the Shape menu select                      
Make Clipping Path.  

Clipping objects can consist of a 
single object, or multiple objects  
that are grouped together to act           
as a single clipped path. 

 

 

♦ A new command, Select Clipping Paths has been added to the Select menu. 

♦ Images, vectors and text can all be used as the clipper or the clippee. 

♦ Clipper objects become grey wireframe, once turned into a clipping path. 

♦ To make clipped objects behave like they were combined, they should be grouped 
together. 

♦ Clipping path containers and clipped objects become grouped after they are made into 
a clipping path.  

♦ All fills, strokes, and cuts attributes are removed from the clipper. As a suggestion, 
clipper objects should be copied to the clipboard before turning them into a clipping 
path then paste back after to assign strokes and fills. 

♦ To assign a cut to a clipping path, you must assign a cut to the clipped object (clipper) 
before making the clipping path. 

♦ Only the area inside the clipping path will output. 
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♦ GSPPlot reduces material usage by eliminating the area outside of the clipping path. 

  

 The larger dimensions represent the overall               
size  of the image in Composer. The smaller  
dimensions are the clipping path. 

GSPPlot reduces the material usage 
by eliminating the area outside of 
the clipping path. 

Dimensioning 
Dimensioning allows you to measure objects, distances, and angles and post these 
measurements on the job. You can choose whether or not to output these dimensions when 
printing from GSPPlot. See “Other GSPPlot feature changes” for more details. 

OMEGA 2.5 Dimension tools include:  

Horizontal (1), Vertical (2), Aligned (3), Angular (4),  
Annotation (5) and Object dimensions (6). 

The dimension Property tool bar allows you to edit the                                                                     
look of the dimensions and the units of measurement.  

 1     2     3      4     5      6 

 

 

♦ Six new dimension tools have been added to the main toolbar. 

♦ The Property toolbar has been added for changing the dimensions display properties.  

♦ Dimensions can be placed on separate layers so they can be hidden or output 
separately. 

♦ Dimensions can be paper printed or EDGE printed, making it easy to create a proof or 
installation layout. 
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Embedded Images 
Images used by PLT files can now be embedded in the PLT file instead of having a link to the 
original image file. If an image is embedded in a PLT file, then the original image file does not 
have to be present as a separate file for rendering to occur. 

To embed a linked image, you can either click the “Embed Images” checkbox when importing 
image files, or select the image and click the Embedded checkbox in the Image Fill dialog box. 

♦ A checkbox has been added to the Image Fill dialog box. When checked the images is 
embedded, if unchecked it remains linked. 

♦ The OMEGA default for embedded images is to keep them linked as in previous 
versions of OMEGA. 

♦ Legacy PLT files will remain linked until they are changed to embedded. 

♦ Once an image is embedded, it cannot be unembedded. It must be deleted, re-
imported, then saved as a linked image (not embedded). 

♦ If an embedded image is the only object being exported, OMEGA displays a message 
box that allows the original image, or the Composer display image, to be exported. 

Layers  
Working with layers is like drawing on transparent sheets. You can put related objects on one 
transparent sheet and move it in front of or in back of other sheets, delete it, choose to view it or 
not view it, and more. It’s a snap to do the following with layers in OMEGA 2.5: 

♦ Put an image on one layer, all the logos on a second layer, and all the text on a third. 

♦ Put all vehicle graphics one layer, and all window graphics on another. 

♦ Put your design on one layer and dimensioning objects on another. 

♦ Add notes to layers for future reference. 

♦ Hide a layer so you can focus on a particular portion of a job. 

♦ At output time, layers get merged into a single unified job as the default. You can also 
select which layers to output or you can choose to treat each layer as a separate job. 

Using Layers in Composer 
To use layers, simply select “Show Layer Manager” from the View menu to open the Layer 
Manager utility window. Every new job has a single default layer called “Layer 1.”  To view 
objects on a layer, double click on a layer name in the Layer Manager. 

♦ .PLT files from previous versions of OMEGA open with one layer that is named the 
same as the .PLT file name. 

♦ Even with a single layer job, you can change the to-front/to-back order of objects in a 
job by clicking and dragging in the layer tree. 

♦ Create additional layers by clicking on the new layer icon, then start dragging and 
dropping objects onto the different layers. 
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Layer Manager 
Layer Manager is a window 
where all actions for layers are 
performed. It provides direct 
and immediate access to all 
layers and their properties as 
well as some object properties.  

 

Choose the double arrow button 
in the Layer Manager to view 
different options for layers. This 
is called Layer menu. 

 

Some layer features and 
capabilities are shown here. 

 

Other layer functions can be 
accessed by right-clicking on an 
object in the Layer tree. 
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New Layer Features 

♦ Layer Manager is movable and dockable and the width can be adjusted.  

♦ Creating new objects and layers – New objects get placed onto the “Current Layer.”  
The current layer is chosen either by clicking on a layer name or by selecting an object. 
The current layer name is displayed above the layer tree and is shown in the Layer 
Manager as highlighted or as blue text. 

♦ Move objects onto different layers by either clicking and dragging them in the layer 
tree, pasting them, or importing them onto the current layer.  

♦ Selecting – Select or deselect objects by clicking on them in the Layer Tree. The 
selection is also shown on the work surface. 

♦ Reordering – Rearrange objects and layers by dragging the layer or objects above (in 
front of) or below (in back of) other layers or objects in the Layer Tree.  

♦ Hiding – Hide or display layers or objects on the work surface by clicking the eye icon 
or choosing the Show or Hide commands in the right-click menu. Hidden layers can 
still be output. 

♦ Locking – Lock or unlock layers by clicking the lock icon or by choosing the Lock or 
Unlock commands in the right-click menu. When layers are locked, you cannot select 
or edit objects on that layer. You can also lock specific objects in the layer tree. Locked  
layers and objects can still be output. 

♦ Notes – you can add design or production notes to each layer of a job. 

♦ Edit All button – If this is on, objects can be edited even if they are not on the current 
layer. If this is off, you must first select a layer name to make it active and then select 
or edit any objects on that layer. Objects on all other layers are locked. 

♦ Merge layers – Multiple layers can be merged into a single layer. The topmost layers 
are in front of lower layers in the viewing order. 

♦ Grouping and layers – Objects from different layers that are grouped are automatically 
moved to the same layer. When objects get selected and grouped, all members of a 
group are moved to be on the same layer as the last selected object. 

♦ Objects from different layers cannot be outlined, distorted, warped, shadowed, or have 
shape effects applied to them.  They must be moved to the same layer by either 
clicking and dragging, merging the selected layers, or grouping 

♦ The same vinyl color or GerberColor Foil can be assigned multiple times to objects on 
different layers.  These colors can also be output multiple time by using the “Output 
by Layers” capability in GSPPlot.  See the “New Layer Features in GSPPlot” for more 
details.  
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♦ Pasting and Layers – Layer information is not preserved when using the clipboard. 
Objects are pasted to the currently selected layer, not necessarily the layer from where 
they were cut or copied. 

♦ Opening OMEGA 2.5 PLT Files with Layers – To prevent unwanted changes to PLT 
files, Layers are always maintained when opening OMEGA 2.5 PLT files with layers. 
When opening PLT files from previous versions of OMEGA or GRAPHIX 
ADVANTAGE with a single layer, the file name is used as the layer name. 

♦ Opening non-PLT files with layers – When opening AI, PDF, EPS or other file types 
with layers, you have two choices: keep the layers or flatten them into a single layer. 

♦ Importing files with and without layers – when importing files (even when importing 
PLT files with layers), you can choose to keep the layers if there are any, or to flatten 
the incoming layers into the current layer or new layer. If a file is imported and 
flattened onto a new layer, the file name is used as the layer name. 

♦ Importing objects – The Import dialog box lets you import objects onto the current 
layer so no new layers are added, import onto a new layer, or maintain the original 
layers from the imported file. If a file is imported onto a new layer, Layer Manager 
even gives the imported new layer the same name as the imported file, making it easy 
to track where objects came from. 

♦ Open/Import Save Preferences – the Preferences push button in the File > 
Open/Import dialog box has been changed to include the saving of the new settings. 
Click OK to save the settings and click Cancel to preserve the previous settings. 

 

♦ Tools > Options > Layout – A Layers group box has been added to allow control over 
how the current layer is chosen and offers the control of new layer warning messages.  
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♦ Arrange Menu – In Front Of and In Back Of. To change the stacking order of an object 
on the work surface, select the object to be moved then select the object on the work 
surface that the originally selected object is to be in front of or in back of. 

  

♦ In the Print/Output Order dialog box – 

♦ A single flattened print order is created for layered jobs if the Output by Layer 
checkbox is turned off. This is the OMEGA 2.5 default setting. 

♦ If the Output by Layer checkbox is on, vinyl output order and GerberColor 
Spot Color print order can be controlled on a layer basis. 

 

♦ File Menu > Output by Layer – You an now choose which layers and vinyl colors to 
output from Composer to GSPPlot. 
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GSPPlot Feature changes due to Layers 
Not only does Composer in OMEGA 2.5 offer great new layers functionality for designing, but 
GSPPlot also offers new flexibility for outputting layers. 

♦ The GSPPlot default when outputting a file is to merge all layers into a single job with 
a single print order. This forces jobs with layers to output like previous GERBER 
OMEGA jobs. 

♦ Layered jobs can also be Output using Layers. If a job is output using layers, each layer 
is treated as a separate job. Outputting by layers can be useful in the following ways: 

♦ Choose to output only certain layers. 

♦ Design several components into a single PLT file using layers, but output each 
component separately. In the GSPPlot toolbar, turn On Reduce Frame and turn 
Off Rewind Between Layers. 

♦ Over print one layer on top of another by choosing the Rewind Between Layers 
command in the Select Colors dialog box. Turn Off Reduce Frame to maintain 
proper registration between layers. This technique allows the same spot color 
or vinyl color to be assigned on different layers and output multiple times in 
the same job. 

♦ If Output by Layers is on, you can cycle through different layers of a job for viewing or 
output by clicking on the Next Vinyl or Previous Vinyl icon in the GSPPlot toolbar. 

  

 Output by Layers can be turned off or on in several locations in GSPPlot. 

 1 Click the Output by Layer icon in the 
toolbar. This icon is grayed out if a job 
only has a single layer. 

 

 2 Open the Select Colors dialog box by 
clicking the icon in the toolbar or from 
the Setup menu. 

                Once in the dialog box, turn Output by 
Layers on or off. 

 

 3 In the Print Options dialog box, turn on 
the Output by Layer checkbox. If on, you 
get a separate print order for each layer. 

                If off, you get a single layer print order. 
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♦ The GSPPlot Select Colors dialog box offers additional check boxes for: 

♦ Large Icons 

♦ Output by Layer 

♦ Merge Layers  

♦ Rewind Between Layers 

♦ Output As Separations 

 
See the chart below for different 
ways to Output by Layer using the 
Select Color dialog Box. 
 

 

GSPPlot output chart 
 

Output 
by 

Layers 

Flatten 
Layers 

Rewind 
After 
Layer 

Reduce Frame Output Result 

Off NA NA ON  

Saves vinyl and 
foil 

All layers are merged and then printed. 
Prints like a single EDGE or MAXX job. 

Default setting for GSPPlot. 

On On On ON  

Saves vinyl and 
foil 

Allows layers to be selected and flattened 
to a single job.  Selected layers print like a 

single EDGE or MAXX job. 

On  Off Off ON  

Saves vinyl and 
foil 

 

Each layer outputs as a separate job 

For printed EDGE or MAXX jobs, this 
means that each layer gets a separate vinyl 
prompt and cutting target, and all colors 
of one layer will print as a separate job. 

The same spot or process colors on 
separate layers will print multiple times 

because each layer is a separate job. 

On Off On OFF 

Maintains 
registration as 
layers print on 

top of each 
other 

For printed EDGE or MAXX jobs, each 
layer will output as a separate job but each 

layer will print on top of each other. The 
same color on separate layers will print 

multiple times. 
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Other Feature Changes 

Other  Composer feature changes 

♦ View menu – You can work in the Wireframe or Filled 
mode. A check mark next to the View menu options 
indicates the current mode.  

 ♦ Filled mode displays the job with the vinyl fill 
colors visible.  

♦ Wireframe mode can be modified to suit the 
way you work through the View menu or on 
the View tab of the Tools > Options dialog box. 

 

♦ Text on the work surface – The TOWS toolbars is now moveable and dockable. Font, 
font height, degrees of slant and degrees of line rotation can be set regardless of the 
current Composer mode. 

Showing and hiding the secondary toolbar has changed. When the secondary toolbar 
is displayed, the button shows a toolbar with an X in it. If it’s not displayed it will just 
be a toolbar. 

 

Other GSPPlot feature changes 

♦ QuickPlot names – Composer now always supplies a file name to QuickPlot to better 
help identify files in GSPPlot, even if that file name is just “Composer 1” or 
“Composer 2.” 

♦ Target Configuration dialog box -  additional check boxes for Print targets using the 
darkest foil in the job and Print targets using black foil (add to the job if needed).  
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♦ Warning messages – Four new messages have been added to the Warning messages 
dialog box:  

♦ Automatically select OPOS targets when an OPOS cutter is selected  

♦ Warn when Reverse Print Order is selected without Reverse  

♦ Warn when Reduce Frame will cause panel re-calculation  

♦ Warn that “Pause Before Rewind” needs specific Edge FX Firmware.  

                              

♦ Print Mode in Print Options – The Print Mode drop down list is now also available in 
the Print Options dialog box in addition to the Device Select dialog box. This setting 
allows the operator to choose 300x300 or 600x300 dpi for Edge printing. 

♦ Layout dialog box – Print Dimension Information check box added. When checked 
any dimension information in the job will print in GSPPlot. 
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Other OMEGA 2.5 feature changes 

♦ Spool file viewer – A new Utility called SplView allows actual output data in spool 
files to be viewed by color. This can serve as a preflight check to reduce any 
unexpected output. Open Spool Viewer by turning on View Spool File in the Save to 
Spool File dialog box or from File > View Existing Spool File or from the OMEGA 
program group. 

  

     
 

 

♦ OMEGA 2.5 Font CD – OMEGA 2.5 requires the OMEGA 2.5 font CD to load fonts 
(both URW and Gerber), Gerber Libraries, GCA files, and the Braille option. When 
installing OMEGA 2.5 a message appears saying you must have the font CD. Older 
Font CDs will no longer work with OMEGA 2.5 

♦ True Type font conversion – Character spacing now works with converted TrueType 
fonts when entered using Enter/Edit Text box. This is not longer limited to only 
Gerber fonts. 

♦ Gerber Vinyl and Foil Palettes – The new palettes to be used with Adobe Illustrator 
and CorelDRAW now list both the vinyl color name and vinyl family such as 225 or 
220. The palettes are located on the OMEGA CD.  See Help topic "Using Gerber 
Palettes in Adobe Illustrator and CorelDRAW" for complete instructions. 

♦ USB support for third party plotters – You can now install third party plotters using 
the USB port. See the topic “Adding or deleting a local plotter “in Help for complete 
instructions. 
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♦ ColorID – Color ID now allows CMYK and RGB values to be entered in as a source 
color that can be matched by target palettes. 
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